Wind River VxWorks RTOS support with Qt 5.5

Wind River VxWorks RTOS support with Qt 5.5

Guest blog by Tuukka Turunen, Qt

Turunen_Tuukka _QT

We have been working together with Wind River to bring Qt 5 on top of their most recent release of VxWorks Real-Time Operating System (RTOS), VxWorks 7, and I am happy to share that we are close to being able to make the new Qt for VxWorks port generally available to commercial licensees based on Qt 5.5 in the coming months.

The earlier version of VxWorks, VxWorks 6.9, has been supported by Qt 4.8 since 2012. Today it is possible to run the Qt 5 goodies such as Qt Quick 2 on top of VxWorks 7. The goal of the new port is to provide a similar level of Qt functionality as the earlier Qt 4 port does, as well as to take advantage of the great graphics capabilities of Qt 5. In addition, Qt Creator IDE has integrated support for VxWorks, and deployment of a Qt application to a development hardware running VxWorks is accomplished with a single click. VxWorks development with Qt 5 can be done using both Windows and Linux development hosts.

The following video clip shows Qt 5.5 on top of VxWorks 7 running on a Freescale i.MX6 development board: https://youtu.be/FIbkY60nRoQ

The new Qt 5.5 port for VxWorks 7 supports most of the essential Qt modules:

  • Qt Core
  • Qt GUI
  • Qt Network
  • Qt QML
  • Qt Quick
  • Qt Quick Controls
  • Qt Quick Dialogs
  • Qt Quick Layouts
  • Qt SQL
  • Qt Test
  • Qt Widgets

In addition to these, the following add-ons are supported:

  • Qt Concurrent
  • Qt Graphical Effects
  • Qt Image Formats
  • Qt OpenGL (only for porting form Qt 4, new applications should use OpenGL support in Qt GUI)
  • Qt Platform Headers
  • Qt SVG
  • Qt XML Patterns

Commercial value-add functionality, such as the Qt Quick Compiler, Qt Charts and Qt Data Visualization are also supported with the new port.

At Qt 5.5 for VxWorks 7 general availability, access will be available to all our existing Qt for VxWorks licensees. After it is released, it is available in the Qt Account for holders of a valid Qt for VxWorks development license. The new port requires VxWorks 7, it is not possible to use earlier VxWorks versions with it. We are of course also very interested in hearing more about your Qt 5.5 for VxWorks needs, please contact our sales to discuss more and to receive an early access evaluation version of the new port.

If you are interested in learning more about Qt 5.5 for VxWorks 7 please contact us.

For more information on VxWorks, click here  or contact Wind River with any of your inquiries.

Tweet about this on TwitterShare on Google+Share on FacebookShare on LinkedInEmail this to someone